$re = '/^\D+$/m';
$str = '"a"
abc dsa
fsdfsd
qěč+ěčřčýřžýř
10
a b- g+ * asfd
100
abc 10 dsa
15
asdfas
2a
-8
a5
something ... and so one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);