use strict;
my $str = '"a"
abc dsa
fsdfsd
qěč+ěčřčýřžýř
10
a b- g+ * asfd
100
abc 10 dsa
15
asdfas
2a
-8
a5
something ... and so one';
my $regex = qr/^\D+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}