package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<start>Four[\s-]*(\d*)<end>`)
var str = `<start>One<end>
<start>Two<end>
<start>Four - 565<end>
<start>Five - 556<end>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}