const regex = /<start>Four[\s-]*(\d*)<end>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<start>Four[\\s-]*(\\d*)<end>', 'g')
const str = `<start>One<end>
<start>Two<end>
<start>Four - 565<end>
<start>Five - 556<end>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}