import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<start>Four[\\s-]*(\\d*)<end>";
final String string = "<start>One<end>\n"
+ "<start>Two<end>\n"
+ "<start>Four - 565<end>\n"
+ "<start>Five - 556<end>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}