import re
regex = re.compile(r"<start>Four[\s-]*(\d*)<end>")
test_str = ("<start>One<end>\n"
"<start>Two<end>\n"
"<start>Four - 565<end>\n"
"<start>Five - 556<end>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")