re = /<start>Four[\s-]*(\d*)<end>/
str = '<start>One<end>
<start>Two<end>
<start>Four - 565<end>
<start>Five - 556<end>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end