$re = '/<start>Four[\s-]*(\d*)<end>/';
$str = '<start>One<end>
<start>Two<end>
<start>Four - 565<end>
<start>Five - 556<end>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);