// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<start>Four[\s-]*(\d*)<end>").unwrap();
let string = "<start>One<end>
<start>Two<end>
<start>Four - 565<end>
<start>Five - 556<end>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}