using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/?img.*[^-]width\s?[:|=]\s?['|""]?)[0-9]+px(.*)>";
string input = @"<img >
<img />
<img >width
<img width >
<img src = "">
<strong><img width=""500px"" style = 'color:5px' width=""500px;"" /></strong>
<img style = 'height:50px;' width=500px />
<strong><img style = 'color:5px' width=""5000px;"" /></strong>
<img style = 'color:5px;width:265px;' />
<img style = 'color:5px;width:50%;' />
<img style = 'width:50%;' />
<img style = 'height:50px;' />
<img style=""width: 5px;"" />";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}