import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/?img.*[^-]width\\s?[:|=]\\s?['|\"]?)[0-9]+px(.*)>";
final String string = "<img >\n"
+ "<img />\n"
+ "<img >width\n"
+ "<img width >\n"
+ "<img src = \"\">\n"
+ "<strong><img width=\"500px\" style = 'color:5px' width=\"500px;\" /></strong>\n"
+ "<img style = 'height:50px;' width=500px />\n"
+ "<strong><img style = 'color:5px' width=\"5000px;\" /></strong>\n"
+ "<img style = 'color:5px;width:265px;' />\n"
+ "<img style = 'color:5px;width:50%;' />\n"
+ "<img style = 'width:50%;' />\n"
+ "<img style = 'height:50px;' />\n"
+ "<img style=\"width: 5px;\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}