re = /(<\/?img.*[^-]width\s?[:|=]\s?['|"]?)[0-9]+px(.*)>/
str = '<img >
<img />
<img >width
<img width >
<img src = "">
<strong><img width="500px" style = \'color:5px\' width="500px;" /></strong>
<img style = \'height:50px;\' width=500px />
<strong><img style = \'color:5px\' width="5000px;" /></strong>
<img style = \'color:5px;width:265px;\' />
<img style = \'color:5px;width:50%;\' />
<img style = \'width:50%;\' />
<img style = \'height:50px;\' />
<img style="width: 5px;" />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end