use strict;
my $str = '<img >
<img />
<img >width
<img width >
<img src = "">
<strong><img width="500px" style = \'color:5px\' width="500px;" /></strong>
<img style = \'height:50px;\' width=500px />
<strong><img style = \'color:5px\' width="5000px;" /></strong>
<img style = \'color:5px;width:265px;\' />
<img style = \'color:5px;width:50%;\' />
<img style = \'width:50%;\' />
<img style = \'height:50px;\' />
<img style="width: 5px;" />';
my $regex = qr/(<\/?img.*[^-]width\s?[:|=]\s?['|"]?)[0-9]+px(.*)>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}