import Foundation
let pattern = #"(<\/?img.*[^-]width\s?[:|=]\s?['|"]?)[0-9]+px(.*)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img >
<img />
<img >width
<img width >
<img src = "">
<strong><img width="500px" style = 'color:5px' width="500px;" /></strong>
<img style = 'height:50px;' width=500px />
<strong><img style = 'color:5px' width="5000px;" /></strong>
<img style = 'color:5px;width:265px;' />
<img style = 'color:5px;width:50%;' />
<img style = 'width:50%;' />
<img style = 'height:50px;' />
<img style="width: 5px;" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}