// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<\/?img.*[^-]width\s?[:|=]\s?['|"]?)[0-9]+px(.*)>"#).unwrap();
let string = "<img >
<img />
<img >width
<img width >
<img src = \"\">
<strong><img width=\"500px\" style = 'color:5px' width=\"500px;\" /></strong>
<img style = 'height:50px;' width=500px />
<strong><img style = 'color:5px' width=\"5000px;\" /></strong>
<img style = 'color:5px;width:265px;' />
<img style = 'color:5px;width:50%;' />
<img style = 'width:50%;' />
<img style = 'height:50px;' />
<img style=\"width: 5px;\" />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}