const regex = /(<\/?img.*[^-]width\s?[:|=]\s?['|"]?)[0-9]+px(.*)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/?img.*[^-]width\\s?[:|=]\\s?[\'|"]?)[0-9]+px(.*)>', '')
const str = `<img >
<img />
<img >width
<img width >
<img src = "">
<strong><img width="500px" style = 'color:5px' width="500px;" /></strong>
<img style = 'height:50px;' width=500px />
<strong><img style = 'color:5px' width="5000px;" /></strong>
<img style = 'color:5px;width:265px;' />
<img style = 'color:5px;width:50%;' />
<img style = 'width:50%;' />
<img style = 'height:50px;' />
<img style="width: 5px;" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}