#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/<html>\\"
Local $sString = "<html>" & @CRLF & _
" <head>" & @CRLF & _
" <style>" & @CRLF & _
" <!--" & @CRLF & _
" p.DefaultaParagraphaFont {" & @CRLF & _
" italic:;" & @CRLF & _
" bold:normal;" & @CRLF & _
" underline:;" & @CRLF & _
" }" & @CRLF & _
" p.aNormala {" & @CRLF & _
" LeftIndent:0.0;" & @CRLF & _
" RightIndent:0.0;" & @CRLF & _
" FirstLineIndent:0.0;" & @CRLF & _
" }" & @CRLF & _
" -->" & @CRLF & _
" </style>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <p class=default>" & @CRLF & _
" <span style="color: #000000; font-size: 8pt; font-family: Arial">" & @CRLF & _
" Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate, " & @CRLF & _
" Gewürze, " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </span>" & @CRLF & _
" <span style="color: #000000; font-size: 8pt; font-family: Arial">" & @CRLF & _
" <b>SENFMEHL</b>" & @CRLF & _
" </span>" & @CRLF & _
" <span style="color: #000000; font-size: 8pt; font-family: Arial">" & @CRLF & _
" , Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte)." & @CRLF & _
" </span>" & @CRLF & _
" </p>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")