# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/<html>\\"
test_str = ("<html>\n"
" <head>\n"
" <style>\n"
" <!--\n"
" p.DefaultaParagraphaFont {\n"
" italic:;\n"
" bold:normal;\n"
" underline:;\n"
" }\n"
" p.aNormala {\n"
" LeftIndent:0.0;\n"
" RightIndent:0.0;\n"
" FirstLineIndent:0.0;\n"
" }\n"
" -->\n"
" </style>\n"
" </head>\n"
" <body>\n"
" <p class=default>\n"
" <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
" Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate, \n"
" Gewürze, \n"
" \n"
" \n"
" \n"
" </span>\n"
" <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
" <b>SENFMEHL</b>\n"
" </span>\n"
" <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
" , Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte).\n"
" </span>\n"
" </p>\n"
" </body>\n"
"</html>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.