import Foundation
let pattern = #"/<html>\\"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<html>
<head>
<style>
<!--
p.DefaultaParagraphaFont {
italic:;
bold:normal;
underline:;
}
p.aNormala {
LeftIndent:0.0;
RightIndent:0.0;
FirstLineIndent:0.0;
}
-->
</style>
</head>
<body>
<p class=default>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate,
Gewürze,
</span>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
<b>SENFMEHL</b>
</span>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
, Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte).
</span>
</p>
</body>
</html>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}