import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/<html>\\\\";
final String string = "<html>\n"
+ " <head>\n"
+ " <style>\n"
+ " <!--\n"
+ " p.DefaultaParagraphaFont {\n"
+ " italic:;\n"
+ " bold:normal;\n"
+ " underline:;\n"
+ " }\n"
+ " p.aNormala {\n"
+ " LeftIndent:0.0;\n"
+ " RightIndent:0.0;\n"
+ " FirstLineIndent:0.0;\n"
+ " }\n"
+ " -->\n"
+ " </style>\n"
+ " </head>\n"
+ " <body>\n"
+ " <p class=default>\n"
+ " <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
+ " Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate, \n"
+ " Gewürze, \n"
+ " \n"
+ " \n"
+ " \n"
+ " </span>\n"
+ " <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
+ " <b>SENFMEHL</b>\n"
+ " </span>\n"
+ " <span style=\"color: #000000; font-size: 8pt; font-family: Arial\">\n"
+ " , Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte).\n"
+ " </span>\n"
+ " </p>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}