use strict;
my $str = '<html>
<head>
<style>
<!--
p.DefaultaParagraphaFont {
italic:;
bold:normal;
underline:;
}
p.aNormala {
LeftIndent:0.0;
RightIndent:0.0;
FirstLineIndent:0.0;
}
-->
</style>
</head>
<body>
<p class=default>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate,
Gewürze,
</span>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
<b>SENFMEHL</b>
</span>
<span style="color: #000000; font-size: 8pt; font-family: Arial">
, Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte).
</span>
</p>
</body>
</html>';
my $regex = qr//<html>\\/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}