// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/<html>\\").unwrap();
let string = "<html>
<head>
<style>
<!--
p.DefaultaParagraphaFont {
italic:;
bold:normal;
underline:;
}
p.aNormala {
LeftIndent:0.0;
RightIndent:0.0;
FirstLineIndent:0.0;
}
-->
</style>
</head>
<body>
<p class=default>
<span style=\"color: #000000; font-size: 8pt; font-family: Arial\">
Schweinefleischwürstchen (Schweinefleisch, Wasser, Speck, Speisesalz, Natriumcitrate,
Gewürze,
</span>
<span style=\"color: #000000; font-size: 8pt; font-family: Arial\">
<b>SENFMEHL</b>
</span>
<span style=\"color: #000000; font-size: 8pt; font-family: Arial\">
, Glukosesirup, Extrakt aus Rosmarin, Dextrose, Gewürzextrakte).
</span>
</p>
</body>
</html>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}