using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"z:Assembly=\""0\"">(?<fieldValue>[^<>]+)<\/value>";
string input = @"<value z:Id=""8"" z:Type=""System.String"" z:Assembly=""0"">Status.</value>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}