package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)z:Assembly=\"0\">(?<fieldValue>[^<>]+)<\/value>`)
var str = `<value z:Id="8" z:Type="System.String" z:Assembly="0">Status.</value>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}