$re = '/z:Assembly=\"0\">(?<fieldValue>[^<>]+)<\/value>/m';
$str = '<value z:Id="8" z:Type="System.String" z:Assembly="0">Status.</value>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);