// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)z:Assembly=\"0\">(?<fieldValue>[^<>]+)<\/value>"#).unwrap();
let string = "<value z:Id=\"8\" z:Type=\"System.String\" z:Assembly=\"0\">Status.</value>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}