const regex = /z:Assembly=\"0\">(?<fieldValue>[^<>]+)<\/value>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('z:Assembly=\\"0\\">(?<fieldValue>[^<>]+)<\\\/value>', 'gm')
const str = `<value z:Id="8" z:Type="System.String" z:Assembly="0">Status.</value>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}