import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "z:Assembly=\\\"0\\\">(?<fieldValue>[^<>]+)<\\/value>";
final String string = "<value z:Id=\"8\" z:Type=\"System.String\" z:Assembly=\"0\">Status.</value>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}