re = /z:Assembly=\"0\">(?<fieldValue>[^<>]+)<\/value>/m
str = '<value z:Id="8" z:Type="System.String" z:Assembly="0">Status.</value>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end