#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)"
Local $sString = "★ Gut Knife | Safari Mesh (Field-Tested)" & @CRLF & _
"★ Falchion Knife | Safari Mesh (Field-Tested)" & @CRLF & _
"★ Gut Knife" & @CRLF & _
"★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)" & @CRLF & _
"★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)" & @CRLF & _
"★ Falchion Knife | Night (Field-Tested)" & @CRLF & _
"" & @CRLF & _
"Falchion Knife | Night (Field-Tested)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")