$re = '/(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)/i';
$str = '★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);