// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)").unwrap();
let string = "★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}