using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)";
string input = @"★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}