import Foundation
let pattern = #"(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)