re = /(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)/i
str = '★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end