#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)"
Local $sString = "Hey $mark" & @CRLF & _
"Hey $mark." & @CRLF & _
"Hey $mark, you're nice" & @CRLF & _
"Hey $mark!!!! I didn't think of that," & @CRLF & _
"foo foo foo foo @mark_markus@gmail.com" & @CRLF & _
"foo@dontmatchthis" & @CRLF & _
"blah @mark.markus blah" & @CRLF & _
"blah blah @mark@gmail.com" & @CRLF & _
"@jozko" & @CRLF & _
"@mark ahoj" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")