const regex = /(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\w$])$([\\w$]+(?:[.!][\\w$]+)*)', 'g')
const str = `Hey \$mark
Hey \$mark.
Hey \$mark, you're nice
Hey \$mark!!!! I didn't think of that,
foo foo foo foo @mark_markus@gmail.com
foo@dontmatchthis
blah @mark.markus blah
blah blah @mark@gmail.com
@jozko
@mark ahoj
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}