re = /(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)/
str = 'Hey $mark
Hey $mark.
Hey $mark, you\'re nice
Hey $mark!!!! I didn\'t think of that,
foo foo foo foo @mark_markus@gmail.com
foo@dontmatchthis
blah @mark.markus blah
blah blah @mark@gmail.com
@jozko
@mark ahoj
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end