import Foundation
let pattern = #"(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hey $mark
Hey $mark.
Hey $mark, you're nice
Hey $mark!!!! I didn't think of that,
foo foo foo foo @mark_markus@gmail.com
foo@dontmatchthis
blah @mark.markus blah
blah blah @mark@gmail.com
@jozko
@mark ahoj
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)