$re = '/(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)/';
$str = 'Hey $mark
Hey $mark.
Hey $mark, you\'re nice
Hey $mark!!!! I didn\'t think of that,
foo foo foo foo @mark_markus@gmail.com
foo@dontmatchthis
blah @mark.markus blah
blah blah @mark@gmail.com
@jozko
@mark ahoj
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);