import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\w$])$([\\w$]+(?:[.!][\\w$]+)*)";
final String string = "Hey $mark\n"
+ "Hey $mark.\n"
+ "Hey $mark, you're nice\n"
+ "Hey $mark!!!! I didn't think of that,\n"
+ "foo foo foo foo @mark_markus@gmail.com\n"
+ "foo@dontmatchthis\n"
+ "blah @mark.markus blah\n"
+ "blah blah @mark@gmail.com\n"
+ "@jozko\n"
+ "@mark ahoj\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}