# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s|^)[^\s]+?.png/myserver.com\/\0/;t' <<< "2016.png random characters vjifj903%.png unpredictable characters"