const regex = new RegExp('(?<=\\s|^)[^\\s]+?.png', '')
const str = `2016.png random characters vjifj903%.png unpredictable characters`;
const subst = `myserver.com/\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);