re = /(?<=\s|^)[^\s]+?.png/
str = '2016.png random characters vjifj903%.png unpredictable characters'
subst = 'myserver.com/\\0'
result = str.sub(re, subst)
# Print the result of the substitution
puts result