$re = '/(?<=\s|^)[^\s]+?.png/';
$str = '2016.png random characters vjifj903%.png unpredictable characters';
$subst = "myserver.com/\0";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;