import re
regex = re.compile(r"(?<=\s|^)[^\s]+?.png")
test_str = "2016.png random characters vjifj903%.png unpredictable characters"
subst = "myserver.com/\\0"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)