using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)[^\s]+?.png";
string substitution = @"myserver.com/\0";
string input = @"2016.png random characters vjifj903%.png unpredictable characters";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}