use strict;
my $str = '2016.png random characters vjifj903%.png unpredictable characters';
my $regex = qr/(?<=\s|^)[^\s]+?.png/p;
my $subst = 'myserver.com/\\0';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";