# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)(#[a-z\d][\w-]*) //gi;t' <<< "ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result "