const regex = /(^|\s)(#[a-z\d][\w-]*) /gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)(#[a-z\\d][\\w-]*) ', 'gi')
const str = `ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);